TSB 20-2339 Vehicle Buck/Surge During Low Speed Operation And/Or Engine Runs Rough After Cold Start

Dan Kobler

Well-Known Member
First Name
Dan
Joined
Dec 17, 2018
Messages
65
Reaction score
59
Location
Minneapolis
Vehicle(s)
XLT SuperCrew 302A 4x4
This is exactly my issue with my 2019 ranger XLT. It seems to only do it when it is cold outside and the initial driving. Soon after things seem to get back to normal. I'll need to take it in soon for a service and will inquire if they can check it out as well. Thanks.
Same here...same here 🙃





Advertisement

 

Dmc

Well-Known Member
First Name
Deb
Joined
Aug 26, 2020
Messages
82
Reaction score
54
Location
Oxford pa
Vehicle(s)
2020 ranger
Occupation
Retired
Ranger not only one that does this . I have had 16 escape 1.6 a 17 Fiesta 5spd man and now a 2020 ranger do this when they are cold . It must be a new ford thing . Just let it warm up
 

DsDad

Member
First Name
DsDad
Joined
Dec 7, 2019
Messages
7
Reaction score
7
Location
Tx
Vehicle(s)
2019 XLT SC Oxford White
I won't disagree, as I don't have any of the vehicles you list. Our 2016 Edge 2.0L Ecoboost runs smoothly when cold, as does the 2019 Ranger, post-update. However, I had a 2013 Honda Accord 2.4L that would run poorly on the second start after I started it cold, shut it off after a few seconds, and then started it again later on.
 

kastory

Member
First Name
Keith
Joined
Oct 16, 2020
Messages
15
Reaction score
24
Location
Findlay, Ohio
Vehicle(s)
2020 Ranger Lariat
Has anyone had the Buck/Surge During Low Speed Operation issue on the 2020's?
 

Trigganometry

Well-Known Member
First Name
Rick
Joined
Dec 4, 2020
Messages
2,207
Reaction score
7,012
Location
Massachusetts
Vehicle(s)
2020 XLT Ranger scab 301A/tow 4X4 magnetic w/sport
Occupation
Engineering
Has anyone had the Buck/Surge During Low Speed Operation issue on the 2020's?
Does it sound like a cement mixer when you drive off? 🤔 Well you didn’t warm it up enough and it bucks to tell you so! Honestly, that’s what mine does and if I’m patient and sit or just use FordPass schedule start before I got to go it’s a non issue from that point on.
 

rangerdanger

Moderator
Joined
Oct 9, 2018
Messages
3,494
Reaction score
2,520
Location
SF Bay Area
Vehicle(s)
2019 Ford Ranger SuperCrew XLT FX4
Vehicle Showcase
1
This has been happening for 6 months and I was going crazy thinking it would go away in Spring. But it's been in the 40s most mornings this Winter and today I finally got this lovely notification in my FordPass app.

I have an appointment to get this TSB applied tomorrow.

IMG_0758.PNG
 

rangerdanger

Moderator
Joined
Oct 9, 2018
Messages
3,494
Reaction score
2,520
Location
SF Bay Area
Vehicle(s)
2019 Ford Ranger SuperCrew XLT FX4
Vehicle Showcase
1
I got my truck back from the service department, I brought a printed copy of the TSB with me. They did a road test and were able to replicate the issue.

They applied the PCM update and it shifts so smoothly now.

This has been happening for 6 months and I was going crazy thinking it would go away in Spring. But it's been in the 40s most mornings this Winter and today I finally got this lovely notification in my FordPass app.

I have an appointment to get this TSB applied tomorrow.

IMG_0758.PNG
 

quirkybar8

Well-Known Member
First Name
Bob
Joined
Dec 2, 2019
Messages
179
Reaction score
184
Location
Indy
Vehicle(s)
2019 Ford Ranger 2WD XLT
I got my truck back from the service department, I brought a printed copy of the TSB with me. They did a road test and were able to replicate the issue.

They applied the PCM update and it shifts so smoothly now.
What caused the MIL?
 

rangerdanger

Moderator
Joined
Oct 9, 2018
Messages
3,494
Reaction score
2,520
Location
SF Bay Area
Vehicle(s)
2019 Ford Ranger SuperCrew XLT FX4
Vehicle Showcase
1
What caused the MIL?
The rear wheels were slipping due to the sudden power drops and surges from the transmission. I also got Traction Control warnings too. So the system thought it was an issue with the 4x4 system.
 

rangerdanger

Moderator
Joined
Oct 9, 2018
Messages
3,494
Reaction score
2,520
Location
SF Bay Area
Vehicle(s)
2019 Ford Ranger SuperCrew XLT FX4
Vehicle Showcase
1
I did a test today and yesterday.

Yesterday I did a cold-start in the morning and there was still some shifting funkiness. But it went away after 10 minutes.

Today I did a remote start in the morning and there was almost no issues. It seems like in both instances the transmission is delayed in downshifting when going uphill. But it resolves itself after 5-10 minutes of driving.
 

quirkybar8

Well-Known Member
First Name
Bob
Joined
Dec 2, 2019
Messages
179
Reaction score
184
Location
Indy
Vehicle(s)
2019 Ford Ranger 2WD XLT
The rear wheels were slipping due to the sudden power drops and surges from the transmission. I also got Traction Control warnings too. So the system thought it was an issue with the 4x4 system.
Damn, when did your trans get that bad? You really feel the re-flash will fix that problem? And one final question :), did you note the FW version before the work? It's not clear to me whether it's an actual change to the strategy, and the TSB doesn't say. With mine only being the "I can't decide if I want to go into 4th" for the first couple minutes, it seems like a lot of trouble to go through.
I did a test today and yesterday.

Yesterday I did a cold-start in the morning and there was still some shifting funkiness. But it went away after 10 minutes.

Today I did a remote start in the morning and there was almost no issues. It seems like in both instances the transmission is delayed in downshifting when going uphill. But it resolves itself after 5-10 minutes of driving.
Even more reason to live with minor shift quirkiness for me. I wonder if your re-learn will help.
 

RANGER PRIDE

Well-Known Member
Joined
Sep 4, 2019
Messages
4,286
Reaction score
8,424
Location
Canada, somewhere. A nomadic traveller
Vehicle(s)
2019 Ranger FX4 Supercrew
I did a test today and yesterday.

Yesterday I did a cold-start in the morning and there was still some shifting funkiness. But it went away after 10 minutes.

Today I did a remote start in the morning and there was almost no issues. It seems like in both instances the transmission is delayed in downshifting when going uphill. But it resolves itself after 5-10 minutes of driving.
when they do the TSB, the transmission has to go through its adaptive process again. so dont be alarmed if it seems funky still.
 

rangerdanger

Moderator
Joined
Oct 9, 2018
Messages
3,494
Reaction score
2,520
Location
SF Bay Area
Vehicle(s)
2019 Ford Ranger SuperCrew XLT FX4
Vehicle Showcase
1
With mine only being the "I can't decide if I want to go into 4th" for the first couple minutes, it seems like a lot of trouble to go through.
This is exactly what was happening before/after the update to the PCM. It seems in 7th gear it wants to downshift to 3rd or 4th but it is delayed for 3-4 seconds.

It's much better after 5-10 minutes of driving but its very annoying & potentially dangerous.
 

dallas121469

Well-Known Member
First Name
Steve
Joined
Aug 27, 2019
Messages
82
Reaction score
104
Location
Idaho
Vehicle(s)
2019 Ford Ranger
Occupation
Sonographer
Sold my beautiful Ranger today due to these issues. I feel like a weight has been lifted from my shoulders. I was a little underwater on my loan but worth it for peace of mind. Good luck everyone.
 

Advertisement





 


Advertisement
Top