SYNC 3 is pissing me off!

Discussion in 'Electronics, SYNC, Audio, Nav, Phone, FORScan' started by CoastieN70, Aug 14, 2019.

  1. CoastieN70

    CoastieN70 Well-Known Member

    First Name:
    Lee
    Vehicle(s):
    2019 Ranger Lariet
    Joined:
    May 31, 2019
    Location:
    Savannah, GA
    Posts:
    328
    Likes Received:
    369
    Occupation:
    Retired
    There are so many quirky bugs in the Ranger Sync 3 that I am miffed to the 10th degree.

    I am not a SYNC 3 virgin, I've had it in my Mustang and Explorer and except for having trouble updating the Mustang (I had auto updates disabled because I was ignorant to its function) it has been completely trouble free in those platforms.

    So I would assume that the Ranger would be good to go out of the box... Nope! I had what I assumed was a Sirus/XM problem and in fact it turn out that a Sync3 reboot cured that problem.
    I've had my NAV System completely stop working, so I pulled over at the next convenience store, shut down the vehicle, use the "facilities", restart and everything worked. Today it dropped my phone, I jumped around a couple "Screens" at a long red light and it repaired my phone. It almost acts like the original SYNC from days gone by.

    I spoke to the "Tech Guy" at my dealership, he knows I am Sync Savvy and he said that he has had to reboot several Rangers for similar quirks and his contact "up the line" says that fixes are coming in the next update, when ever the heck that may be.

    Basically I am just venting but for those that are having Sync Gremlins, you are not alone and I feel your pain...
     
    Murphie and Tracy Bowman like this.
  2. DHMag

    DHMag Well-Known Member

    First Name:
    Dale
    Vehicle(s):
    2016 Kia Optima SX, 2019 Ranger XLT Crew cab
    Joined:
    Oct 25, 2018
    Location:
    San Antonio, TX
    Posts:
    298
    Likes Received:
    203
    What is the build number of your SYNC 3 ? It should be, if I'm not mistaken, 19052.
     
  3. kieefer

    kieefer Well-Known Member

    First Name:
    kieefer
    Vehicle(s):
    2019 Ranger Lariat SuperCab
    Joined:
    Dec 26, 2017
    Location:
    Tennessee
    Posts:
    303
    Likes Received:
    241
    I have yet to see an update or acknowledgement that one is not needed.

    Just a spinning circle that disappears.
     
    kjbeggs likes this.
  4. UofMEngineer

    UofMEngineer Well-Known Member

    Vehicle(s):
    17' Ford Escape Titanium, 18' Ford Fusion Hybrid Titanium
    Joined:
    Apr 19, 2019
    Location:
    Michigan
    Posts:
    96
    Likes Received:
    36
    Occupation:
    SYNC 3 Voice Recognition Engineer
    If you're not on 19052 (Settings -> General -> About SYNC), you can get it from the owner portal website as well.
     
  5. kieefer

    kieefer Well-Known Member

    First Name:
    kieefer
    Vehicle(s):
    2019 Ranger Lariat SuperCab
    Joined:
    Dec 26, 2017
    Location:
    Tennessee
    Posts:
    303
    Likes Received:
    241
    Version 3.3
    Build 18351
     
  6. UofMEngineer

    UofMEngineer Well-Known Member

    Vehicle(s):
    17' Ford Escape Titanium, 18' Ford Fusion Hybrid Titanium
    Joined:
    Apr 19, 2019
    Location:
    Michigan
    Posts:
    96
    Likes Received:
    36
    Occupation:
    SYNC 3 Voice Recognition Engineer
    You're 2 builds back from the latest. Pull the latest from the owner portal. Same for you @CoastieN70, it may address some of your issues if you're on an older release.
     
    SubVet likes this.
  7. DBaz

    DBaz Well-Known Member

    First Name:
    Dan
    Vehicle(s):
    '19 Ford Ranger Lariat FX4
    Joined:
    May 5, 2019
    Location:
    Oregon
    Posts:
    140
    Likes Received:
    110
    Not everyone is able to access the file on Ford's portal...I had this problem despite disabling all security software, rebooting and enabling all javascript. All I got was the spinning circle and a message saying "Validating." This was the case with every browser I tried.

    May have been a coincidence but when I simultaneously turned on accessory power to the truck I was able to access the file.

    The update did solve a few issues.
     
  8. kieefer

    kieefer Well-Known Member

    First Name:
    kieefer
    Vehicle(s):
    2019 Ranger Lariat SuperCab
    Joined:
    Dec 26, 2017
    Location:
    Tennessee
    Posts:
    303
    Likes Received:
    241
    Honestly I haven’t noticed any annoying quirks besides a message now and then but I’m usually stuck on Sirius channel surfing,
     
  9. UofMEngineer

    UofMEngineer Well-Known Member

    Vehicle(s):
    17' Ford Escape Titanium, 18' Ford Fusion Hybrid Titanium
    Joined:
    Apr 19, 2019
    Location:
    Michigan
    Posts:
    96
    Likes Received:
    36
    Occupation:
    SYNC 3 Voice Recognition Engineer
    I'd guess coincidence. Maybe some site issue the day you were trying to download or something. Usually the browser switch and ad blocking disable fixes all those issues though.

    19052 will get rid of one of the annoying pop-ups, so one less annoyance perhaps.
     
  10. Fordguy

    Fordguy Well-Known Member

    First Name:
    Rich
    Vehicle(s):
    2019 Ranger
    Joined:
    May 1, 2019
    Location:
    San Clemente, Ca
    Posts:
    87
    Likes Received:
    108
    Occupation:
    Fixed operation Director Tuttle Click Automotive
    Garage Profiles:
    1
    Mine has been flawless flawless.
     
    SubVet and CoastieN70 like this.
  11. RedlandRanger

    Moderator

    First Name:
    Rob
    Vehicle(s):
    2019 Ford Ranger Lariat FX4, 1973 Mercury Capri
    Joined:
    Nov 14, 2018
    Location:
    Oregon City, OR
    Posts:
    2,187
    Likes Received:
    1,776
    Garage Profiles:
    1
    My only issue after the 19052 update is that I get an intermittent stuttering voice. Apparently that is a known issue and will be fixed "in the next release".
     
  12. MINI Ranger

    MINI Ranger Active Member

    First Name:
    Gene
    Vehicle(s):
    2019 Ranger Lariat FX4, 2014 MINI Cooper S Clubman
    Joined:
    May 17, 2019
    Location:
    Texas
    Posts:
    36
    Likes Received:
    32
    Occupation:
    ASE Master Technician, MINI Technician, Retired
    Garage Profiles:
    1
    20190814_181433(0).jpg I have the current version of Sync3 and experienced a problem with navigation. After my truck was parked in an underground parking facility, I had a no GPS symbol displayed in the lower left corner and navigation functions did not work. Quite inconvenient to those needing navigation to get home.
    I tried a key cycle at first stoplight, but no help.
    Truck had to sit outside for a few minutes for the system to find GPS signal.
    Seems that system could have connected to GPS satellite when I drove out of parking building.
     
  13. OP
    OP
    CoastieN70

    CoastieN70 Well-Known Member

    First Name:
    Lee
    Vehicle(s):
    2019 Ranger Lariet
    Joined:
    May 31, 2019
    Location:
    Savannah, GA
    Posts:
    328
    Likes Received:
    369
    Occupation:
    Retired
    Just like loosing Sirus/Xm going under a bridge or a bunch of trees, you vehicle has to be able to see a satellite in order for NAV to function. I have experienced the "No GPS symbol after just such a situation, it takes longer for your vehicle to acquire the GPS Sat than the Sirus Sat., cycling the ignition should not be necessary, been there experienced that with the Explorer and the Mustang. My loss of NAV (No GPS symbol present) was when my Ranger was completely in the open and fully able to "see" the Sat.
     
  14. OP
    OP
    CoastieN70

    CoastieN70 Well-Known Member

    First Name:
    Lee
    Vehicle(s):
    2019 Ranger Lariet
    Joined:
    May 31, 2019
    Location:
    Savannah, GA
    Posts:
    328
    Likes Received:
    369
    Occupation:
    Retired
    Been running 19052 since day one with my Ranger...
     
  15. MINI Ranger

    MINI Ranger Active Member

    First Name:
    Gene
    Vehicle(s):
    2019 Ranger Lariat FX4, 2014 MINI Cooper S Clubman
    Joined:
    May 17, 2019
    Location:
    Texas
    Posts:
    36
    Likes Received:
    32
    Occupation:
    ASE Master Technician, MINI Technician, Retired
    Garage Profiles:
    1
    Yes, GPS does lose it's signal under bridges, trees and other aerial obstructions but reconnects when obstruction is removed.
    The problem with mine is it's inability to reconnect. I should not have to park outside the parking garage, shut off vehicle and wait until system reboots in order to go on my way. I was alone yesterday in stop and co traffic and was not able to play with controls much on my almost hour long trip home.
    When I arrived, I cycled the key but icon was still there and navigation was still lost. After 30 minutes, I started truck again and after a longer than normal startup time, the navigation system knew where it was.
     

Share This Page