Power steering failed

garo1943

Member
First Name
Gary
Joined
Oct 4, 2019
Messages
8
Reaction score
6
Location
Georgia
Vehicle(s)
2019 Ranger Lariat/2019 lincoln Navigator/2015 Volkswagen Bettle R/Line Convertible
Occupation
Retired
I pulled into a parking place and the dash looked like an arcade. Electric assist for steering has failed along with the following:
Advance Traction Control has failed
PreCollision has failed
Lane Keeping has failed
Adaptive Cruise has failed
Hill Start Assist has failed
I turned the truck off and restarted still no power steering and all the warning lights came on waited about 20 minutes and all was well. Called the dealer and they said to bring it in. I drove the next day to the dealer about halfway there everything stopped working again . Made it to the dealer and they saw the light show. They said they had never seen that before has anyone else experienced this? I have 1300 miles on the truck and I am very disappointed and concerned as i have just went thru a buy back on a 2019 BMW X5 with some of the same problems. It was like a nasty divorce, One bright spot
the truck sent a message to Ford Pass with all the failures so there is a log.





Advertisement

 

RedlandRanger

Moderator
First Name
Rob
Joined
Nov 14, 2018
Messages
3,394
Reaction score
4,209
Location
Oregon
Vehicle(s)
2019 Ford Ranger Lariat FX4, 1973 Mercury Capri
Vehicle Showcase
1
I pulled into a parking place and the dash looked like an arcade. Electric assist for steering has failed along with the following:
Advance Traction Control has failed
PreCollision has failed
Lane Keeping has failed
Adaptive Cruise has failed
Hill Start Assist has failed
I turned the truck off and restarted still no power steering and all the warning lights came on waited about 20 minutes and all was well. Called the dealer and they said to bring it in. I drove the next day to the dealer about halfway there everything stopped working again . Made it to the dealer and they saw the light show. They said they had never seen that before has anyone else experienced this? I have 1300 miles on the truck and I am very disappointed and concerned as i have just went thru a buy back on a 2019 BMW X5 with some of the same problems. It was like a nasty divorce, One bright spot
the truck sent a message to Ford Pass with all the failures so there is a log.
There have been several reports of loose connections and/or pins in connectors. One connector in particular is behind the driver's side headlight. There have been a couple other problematic connections for others as well.
 
OP

garo1943

Member
First Name
Gary
Joined
Oct 4, 2019
Messages
8
Reaction score
6
Location
Georgia
Vehicle(s)
2019 Ranger Lariat/2019 lincoln Navigator/2015 Volkswagen Bettle R/Line Convertible
Occupation
Retired
  • Thread starter
  • Thread Starter
  • #3
I pulled into a parking place and the dash looked like an arcade. Electric assist for steering has failed along with the following:
Advance Traction Control has failed
PreCollision has failed
Lane Keeping has failed
Adaptive Cruise has failed
Hill Start Assist has failed
I turned the truck off and restarted still no power steering and all the warning lights came on waited about 20 minutes and all was well. Called the dealer and they said to bring it in. I drove the next day to the dealer about halfway there everything stopped working again . Made it to the dealer and they saw the light show. They said they had never seen that before has anyone else experienced this? I have 1300 miles on the truck and I am very disappointed and concerned as i have just went thru a buy back on a 2019 BMW X5 with some of the same problems. It was like a nasty divorce, One bright spot
the truck sent a message to Ford Pass with all the failures so there is a log.
 
OP

garo1943

Member
First Name
Gary
Joined
Oct 4, 2019
Messages
8
Reaction score
6
Location
Georgia
Vehicle(s)
2019 Ranger Lariat/2019 lincoln Navigator/2015 Volkswagen Bettle R/Line Convertible
Occupation
Retired
  • Thread starter
  • Thread Starter
  • #4
Had a call from dealer yesterday they have determined it is the electric steering gear box. Has anyone heard of this issue, Will be a WEEK or longer no parts??
 
OP

garo1943

Member
First Name
Gary
Joined
Oct 4, 2019
Messages
8
Reaction score
6
Location
Georgia
Vehicle(s)
2019 Ranger Lariat/2019 lincoln Navigator/2015 Volkswagen Bettle R/Line Convertible
Occupation
Retired
  • Thread starter
  • Thread Starter
  • #5
Had a call from dealer yesterday they have determined it is the electric steering gear box. Has anyone heard of this issue, Will be a WEEK or longer no parts??
 
OP

garo1943

Member
First Name
Gary
Joined
Oct 4, 2019
Messages
8
Reaction score
6
Location
Georgia
Vehicle(s)
2019 Ranger Lariat/2019 lincoln Navigator/2015 Volkswagen Bettle R/Line Convertible
Occupation
Retired
  • Thread starter
  • Thread Starter
  • #6
Still no parts been at the dealer for 2 weeks that sucks
 

u wish u could ride

Well-Known Member
First Name
robert
Joined
Jul 30, 2019
Messages
283
Reaction score
423
Location
shelton ct
Vehicle(s)
19 xlt in blue
Occupation
building maintenance
what did they give you as a loaner? cant they take one out of a sitting truck it being so long?
 

dmeyer302

Well-Known Member
First Name
Daniel
Joined
Feb 18, 2019
Messages
596
Reaction score
1,134
Location
Carthage, MO
Vehicle(s)
1991 F-150, 2014 Escape
Occupation
Mechanical Engineer
Vehicle Showcase
1
The EPAS in my sister’s Focus went out earlier this year. Not a big deal to change, just time and $$. Unfortunately it’s a part that we’re going to have to expect to croak periodically.
 
OP

garo1943

Member
First Name
Gary
Joined
Oct 4, 2019
Messages
8
Reaction score
6
Location
Georgia
Vehicle(s)
2019 Ranger Lariat/2019 lincoln Navigator/2015 Volkswagen Bettle R/Line Convertible
Occupation
Retired
  • Thread starter
  • Thread Starter
  • #9
They gave me a Fusion Hybrid not a bad car but not a Ranger. The parts finally came in and I should be able to pick it up today.Yea
 

DickyGray

New Member
First Name
Richard
Joined
Sep 20, 2017
Messages
3
Reaction score
0
Location
LONDON
Vehicle(s)
Ranger Wildtrak 18/Audi tts/BMW R Nine T/
Occupation
Controls Engineer
This exact thing has happened to me yesterday, been having intermittent issues with starting the truck, dead ignition. It always clears itself, until yesterday. Now i have the full set of bad lights and no working truck.
Found a loose bolt on the solid copper link at the back right side of the battery, will not tighten properly. feels threaded to me.
has something fried from the continual arc-ing thats been going on ?
 

Mokume

Well-Known Member
First Name
Jeff
Joined
Aug 18, 2019
Messages
1,312
Reaction score
1,531
Location
Honolulu, Hawaii
Vehicle(s)
2000 Ranger Supercab (sold 12/19) , 2002 Honda CR-V
Occupation
Retired Firefighter III, Honolulu Fire Department
This exact thing has happened to me yesterday, been having intermittent issues with starting the truck, dead ignition. It always clears itself, until yesterday. Now i have the full set of bad lights and no working truck.
Found a loose bolt on the solid copper link at the back right side of the battery, will not tighten properly. feels threaded to me.
has something fried from the continual arc-ing thats been going on ?
Do you see evidence of arcing going on at this link? If so, that can't be good for the electronics on board the truck. I'll check mine later when it's light.

Possibly related, but I did notice that there are 2 sizeable ground cables located within the left front wheel well area attached to the frame. This location is great for serviceability but no doubt will cause problems for those owners living in the rust belt or where chemicals are used to de-ice roads as the truck matures.

I suggest removing them and to clean/sand the contact areas to shiny bare metal, re-attach the bolts using anti-seize on the threads and spritzing the area with something like LPS 3 or even paint.

Thanks for jogging my memory on arcing, I'll do these 2 grounds later, can' hurt.
 

DickyGray

New Member
First Name
Richard
Joined
Sep 20, 2017
Messages
3
Reaction score
0
Location
LONDON
Vehicle(s)
Ranger Wildtrak 18/Audi tts/BMW R Nine T/
Occupation
Controls Engineer
Afraid so, the red plastic cover has melted a little around the bolt access. Just before it went real bad, the bolt was HOT. The solid copper bar attached to that is not looking very happy either. As far as the fault messages we are getting, does anyone know if a particular module or fuse is responsible for the operation of all of these facilities?
 

DickyGray

New Member
First Name
Richard
Joined
Sep 20, 2017
Messages
3
Reaction score
0
Location
LONDON
Vehicle(s)
Ranger Wildtrak 18/Audi tts/BMW R Nine T/
Occupation
Controls Engineer
I’m still well within warranty, but having taken the battery out to charge after a spell overseas, I may be responsible for this mess.
 

Langwilliams

Well-Known Member
First Name
Langley
Joined
Dec 31, 2019
Messages
788
Reaction score
1,088
Location
Lorain, Ohio
Vehicle(s)
2019 Ford Ranger XLT, 2014 Harley Street Glide
Occupation
Mail Carrier
I put 66K on my 16 Fusion with electric power steering an I never had a problem.
 

Advertisement





 


Advertisement
Top