Multiple Fault Codes - 2019 FX4

fortywater12

Member
First Name
Evan
Joined
May 17, 2021
Messages
13
Reaction score
12
Location
San Diego
Vehicle(s)
2019 Ranger XLT FX4
Occupation
Engineer
Recently picked up my 2019 Ranger XLT FX4 about 4 weeks ago. 2 weeks into ownership I got multiple fault codes when backing out of a parking spot at the grocery store. The codes were as follows (pulled from Ford Pass):

  • Powertrain Malfunction / Reduced Power
  • Hill Start Assist Warning
  • Pre-Collision Assist Not Available
The truck would flash a bunch of error messages and the traction control light would be on, as well as the service wrench light. After I parked the truck when I got home for a couple of minutes and fired it back up, the codes were all gone. I called the dealer the next day and they basically said don't worry about it unless they come back.

Fast forward another week, and I got the same set of codes 3 times in one day, all while driving the vehicle. From reading around on the forum, it sounds like this is an ABS module issue, or an ABS/Speed Sensor issue.

I brought the truck into Ford and they were looking at it and the feedback was "we couldn't replicate the code during road tests, but the tech was able to pull a code from the PCM. We checked the TSBs for the code and couldn't find anything. We will clear the PCM and release the vehicle back to you".

At this point, I told the service advisor that I was not happy with that response. I asked for more information about the code they pulled and he said he would follow up with the technician who did the investigation/work on my truck. Is it common for step 1 of troubleshooting to just clear the code and release it back to the owner? Then if it happens again they will start swapping sensors? I'm a little upset because it took me about a week to get my service appointment, and I am almost certain unless they replace or re-position something, the codes will come up again within one week.

Appreciate any insight/comments/responses. I will keep everyone posted on the outcome - supposedly I will get my truck back today.





Advertisement

 
OP

fortywater12

Member
First Name
Evan
Joined
May 17, 2021
Messages
13
Reaction score
12
Location
San Diego
Vehicle(s)
2019 Ranger XLT FX4
Occupation
Engineer
  • Thread starter
  • Thread Starter
  • #3
sounds like a loose connector, those smarter than me will be along in a few to tell you where to start checking, i believe this problem has been discussed before. welcome to wack job world! lol
Haha, thank you. 🍻
 
OP

fortywater12

Member
First Name
Evan
Joined
May 17, 2021
Messages
13
Reaction score
12
Location
San Diego
Vehicle(s)
2019 Ranger XLT FX4
Occupation
Engineer
  • Thread starter
  • Thread Starter
  • #4
Update: Service advisor called me back. He said the code self cleared in the PCM and that sometimes newer vehicles do this, meaning the code is not active.

This is obvious to me, the speed/abs sensor doesn't store any data, so the code is only active when its malfunctioning. The minute it corrects itself or I power cycle the truck, it clears, right?

I asked him to please have the tech check the abs/speed sensor connectors and wiring. Hopefully they do the check for me and I don't have to crawl around under the truck when I get it back.
 

Frenchy

Well-Known Member
First Name
Chris
Joined
Mar 15, 2020
Messages
2,199
Reaction score
1,895
Location
Colorado Springs
Vehicle(s)
2019 Ford Ranger,
Occupation
Crown Forklift Technician
I hope they told you what DTC you had set in the PCM. Something that is coming to happen when the check engine light goes on is other things like abs and stability track anything related to traction control will set a warning because a check engine light is on. Why is that? Simply for the fact that the engine and transmission which is controlled by the p c m are used for traction control purposes.
 

SICKQK

Well-Known Member
First Name
Mark
Joined
Mar 18, 2020
Messages
56
Reaction score
134
Location
NY State
Website
www.saddlebrookcontrols.com
Vehicle(s)
2020 Ford Ranger XLT Crew Cab FX4
Occupation
Automation Applications Engineer
You're much calmer the I would be in your shoes.

Where I live (NY tristate) there would a good chance I could end up as a hood ornament on a Kenworth if the car faulted when merging onto the Turnpike or Thruway.

That is seriously a dangerous situation to have the truck go into limp mode at the wrong time. I know I had it happen with an F-150 I owned and it was no joke.

I hope they find the problem and fix it quick for you.
 
Last edited:

rang19ca

Well-Known Member
First Name
Chuck
Joined
Apr 29, 2019
Messages
761
Reaction score
1,919
Location
Carpinteria Ca
Vehicle(s)
2019 Ranger XLT 4X4 2020 Escape AWD Hybrid
Occupation
Retired Diesel Mechanic
Sadly too many dealers operate like this today. They know Ford corporate will not reimburse them without a hard part failure. Hopefully your struck settles in and does not act up again.
 

AdamHarris

Well-Known Member
First Name
Adam
Joined
Feb 26, 2021
Messages
347
Reaction score
685
Location
Jackson TN
Vehicle(s)
2020 Ford F$%&@n Ranger XLT FX4 Black Supercrew
Occupation
Collision Repair Instructor
Vehicle Showcase
1
Check the abs sensor wiring going out To your steering knuckles on both sides. Several forum members have reported your exact faults and it’s a pinched or faulty wire or harness in that area.
 

TremorOwner

Banned
Joined
May 16, 2021
Messages
300
Reaction score
238
Location
Georgia
Vehicle(s)
2021 Ranger Tremor
Classic speed sensor issue. Either it's a bad sensor or the connector is bad or wiring is bad.

HIGHLY doubt you have a bad ABS controller. Fords LIGHT UP when a single speed sensor is pooped.
 
OP

fortywater12

Member
First Name
Evan
Joined
May 17, 2021
Messages
13
Reaction score
12
Location
San Diego
Vehicle(s)
2019 Ranger XLT FX4
Occupation
Engineer
  • Thread starter
  • Thread Starter
  • #10
Thanks for all of the replies. Another update: the dealer released the vehicle back to me without any solution. Of course, the truck threw the code on my way home, and again today when running an errand. I am going to inspect the speed sensors and download forscan to see if I can pinpoint it myself. I will be calling the dealer to schedule yet another appointment.
 

StarLord

Member
First Name
Matt
Joined
Jan 21, 2020
Messages
24
Reaction score
62
Location
BC Canada
Vehicle(s)
2019 Ranger XL STX FX4
go for a test drive with the tech when you drop it off at the dealership the next time.
 

Trigganometry

Well-Known Member
First Name
Rick
Joined
Dec 4, 2020
Messages
1,648
Reaction score
4,886
Location
Massachusetts
Vehicle(s)
2020 XLT Ranger scab 301A/tow 4X4 magnetic w/sport
Occupation
Engineering
Check the connector in front of the battery and below left front headlight. I know it’s hell to get to. It’s a main harness connector. We have had some here that it wasn’t seated all the way and acted the same too.
 

TremorOwner

Banned
Joined
May 16, 2021
Messages
300
Reaction score
238
Location
Georgia
Vehicle(s)
2021 Ranger Tremor
Eff that, I'd take a picture of the dash and drive it straight to the dealer when it happens and say here's the problem, I'll take a loaner car you can effing fix this right the eff now and stop playing.

:)
 

JimInAllen

Active Member
First Name
Jim
Joined
May 27, 2021
Messages
40
Reaction score
67
Location
Texas
Vehicle(s)
2021 Ford Ranger STX SuperCrew 2WD
Occupation
Cybersecurity Consultant
Mine is doing the same thing as well. No fix so far. 788 miles and goin on my third trip to the dealer on Monday.
 
OP

fortywater12

Member
First Name
Evan
Joined
May 17, 2021
Messages
13
Reaction score
12
Location
San Diego
Vehicle(s)
2019 Ranger XLT FX4
Occupation
Engineer
  • Thread starter
  • Thread Starter
  • #15
go for a test drive with the tech when you drop it off at the dealership the next time.
Definitely going to when I drop it off next. I previously dropped it off super early, so the techs were not there. I plan on dropping it off mid-morning of lunch-time next time I visit; likely this week.

Check the connector in front of the battery and below left front headlight. I know it’s hell to get to. It’s a main harness connector. We have had some here that it wasn’t seated all the way and acted the same too.
Thank you! I will check this out.

Eff that, I'd take a picture of the dash and drive it straight to the dealer when it happens and say here's the problem, I'll take a loaner car you can effing fix this right the eff now and stop playing.

:)
Yep, already took a picture and a video, I hope I can get it to throw the code when I drive it to them for my next service appointment. Thankfully they have been very open to giving me a loaner and the service manager said "when you experience this again, please bring it in and we will get you a loaner vehicle". He was very apologetic they couldn't find the issue. I assume they are not authorized or will not get reimbursed by Ford if they can't prove part failure. I understand the bureaucratic BS, it is just very frustrating and terrible to be on the receiving end of.

Update for everyone: I got the truck back and took if for a wash at a self service wash place. On my way home, the truck threw the codes again and they would not clear. Finally, when I parked it overnight, they finally cleared the next morning. The truck threw the codes 1 more time the next morning on my way to work, but did not throw them at all over the weekend and I did a fair bit of driving. Maybe some water helped it short after the wash, not sure.

In other news, I am experiencing the infamous drive-line clunk a lot of others have experienced here when coming to a stop and starting. When the trunks weight shifts back/forth during a stop or a start, I feel a clunk in the driveline. If I let off the brakes quick enough from a stop, same thing, get a thud or a clunk. I've read to check and lube the slip splines, check the strut torques, check the sway torques, check center support bearing on driveshaft, etc. I guess I'll add this to the list of things to check when I drop my truck off again. All around crappy feeling if I am being honest. I absolutely LOVE this truck, but these little things are absolutely ruining my experience with it so far. If these 2 these were taken care of, it would be a 10/10, in my opinion.
 

Advertisement





 


Advertisement
Top